O'Reilly logo

Web Design in a Nutshell, 2nd Edition by Jennifer Niederst Robbins

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Platform/Browser Support

PNG was designed to be network-friendly, so naturally it is recognized and supported on all platforms. While PNG graphics can be viewed on the majority of browsers in use today (Versions 4 and up of the “Big Two,” except IE4 on the Mac), support for advanced features such as alpha-transparency and gamma correction remains inconsistent, buggy, and conspicuously broken.

Initially, in Navigator and Internet Explorer, PNGs could only be handled as embedded objects (placed with the <embed> tag) and viewed with plug-ins such as PNG Live. Eventually, PNGs became supported as inline images (placed with the <img> tag, like any other web graphic).

As of this writing, the leader in complete PNG implementation is Internet Explorer 5.0 for the Macintosh (unfortunately, the PC team has not followed suit, and PNG support on IE remains buggy for Windows). Netscape 6 also does a good job of supporting PNG’s more interesting features.

Table 21-1 lists the more popular browsers capable of displaying PNGs and the features they support. Note that there are a myriad of lesser-known browsers out there that also support PNG in all its glory. For a complete list of PNG behavior on all browsers, see the browser support page on the official PNG web site at http://www.libpng.org/pub/png/pngapbr.html.

Table 21-1. Browser support for PNG

Browser

Progressive display

Binary transparency

Alpha-channel transparency

Gamma correction

Windows

IE 6 (beta)

Yes

partial

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required