true, false — Provide Truth Values

Synopsis

/usr/bin/true 
/usr/bin/false 

Description

true does nothing, successfully. false does nothing, unsuccessfully. They are typically used in a shell script sh as:

while true 
  do 
    command 
  done 

which executes command forever.

Exit Status

true 0.
false A non-zero value.

Attributes

See attributes(5) for descriptions of the following attributes:

Attribute Type Attribute Value
Availability SUNWcsu

See Also

sh(1), attributes(5)

Get Solaris™ 7 Reference now with the O’Reilly learning platform.

O’Reilly members experience books, live events, courses curated by job role, and more from O’Reilly and nearly 200 top publishers.