O'Reilly logo

Mastering Metasploit by Nipun Jaswal

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Automated exploitation in Metasploit

Recent versions of the Metasploit framework do not support the famous db_autopwn plugin. The db_autopwn plugin is used to attack the hosts and vulnerabilities stored in the database during a penetration test automatically, based on the match made with the existing Metasploit modules.

However, due to its removal from the recent versions, we are not able to use this feature. To be honest, db_autopwn proves to be very handy while conducting a large penetration test and carrying out a quick test of various services with numerous exploits, one-by-one, automatically. So, how we can re-enable this feature in the latest version of the Metasploit framework? The answer to this question is by putting the db_autopwn script ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required