Route Summarization

The default behavior of EIGRP is to summarize on network-number boundaries. This is similar to RIP and IGRP and is a prudent way for a routing protocol to reduce the number of routes that are propagated between routers. However, there are some enhancements in the way EIGRP summarizes routes that merit a closer look.

Automatic Summarization

Say TraderMary’s network expands again, this time with a node in Shannon. Shannon gets connected to the London office via a 56-kbps link, as shown in Figure 4-9.

Route summarization

Figure 4-9. Route summarization

Shannon has three Ethernet segments with an IP subnet on each: 172.20.100.0/24, 172.20.101.0/24, and 172.20.102.0/24. The routers in London and Shannon are configured to run EIGRP 10 in keeping with the routing protocol in use in the U.S. Shannon will advertise 172.20.0.0/16 to London because the serial link from London to Shannon represents a network-number boundary (172.20.0.0/172.16.0.0). Shannon itself will see all 172.16.0.0 subnets (without summarization) because it has a directly connected 172.16.0.0 network.

In EIGRP, the router doing the summarization will build a route to null0 (line 18) for the summarized address. Let’s check Shannon’s routing table:

    Shannon#sh ip route 172.20.0.0
    ...
         172.20.0.0/16 is subnetted, 6 subnets
    C       172.20.100.0/24 is directly connected, Ethernet0
    C       172.20.101.0/24 is directly connected, Ethernet1
18  D       172.20.0.0/16 is a summary, 00:12:11, Null0
    C       172.20.102.0/24 is directly connected, Ethernet2

The route to null0 ensures that if Shannon receives a packet for which it has no route (e.g., 172.20.1.1), it will route the packet using the null interface, thereby dropping the packet, rather than using some other route for the packet (such as a default route).

Now, let’s muddy the picture up a bit. TraderMary acquires a small company in Ottawa which also happens to use a 172.20.0.0 subnet -- 172.20.1.0! The new picture looks something like Figure 4-10.

TraderMary’s networks in Shannon and Ottawa

Figure 4-10. TraderMary’s networks in Shannon and Ottawa

Ottawa is also configured to run EIGRP 10 with a link from NewYork. Since the IP address on the link is 172.16.0.0, Ottawa will send a summary update of 172.20.0.0 to NewYork.

We have a problem now. There are two sources advertising 172.20.0.0, and depending on where we are in the network, we will be able to route only to Ottawa or Shannon. Thus, NewYork will install 172.20.0.0 only via Ottawa, and London will install 172.20.0.0 only via Shannon.

Unlike RIP and IGRP, EIGRP provides the option of disabling route summarization. Thus, Shannon and Ottawa can be configured as follows:

hostname Shannon
...
router eigrp 10
network 172.16.0.0
network 172.20.0.0
no auto-summary 


hostname Ottawa
...
router eigrp 10
network 172.16.0.0
network 172.20.0.0
no auto-summary

When no auto-summary is turned on, Shannon and Ottawa will advertise their subnets to the rest of the network. The subnets happen to be unique, so any router will be able to route to any destination in the network.[6]

Note that no auto-summary was required only on the Shannon and Ottawa routers. NewYork and London and other routers will pass these subnets through (without summarizing them). Summarization happens only at a border between major network numbers, not at other routers.

The moral of this story is that EIGRP networks do not have to be contiguous with respect to major network numbers. However, I do not recommend deliberately building discontiguous networks. Summarizing on network-number boundaries is an easy way to reduce the size of routing tables and the complexity of the network. Disabling route summarization should be undertaken only when necessary.

Manual Summarization

EIGRP allows for the summarization of (external or internal) routes on any bit boundary. Manual summarization can be used to reduce the size of routing tables.

In our example, the network architect may decide to allocate blocks of addresses to NewYork, Ames, Chicago, etc. NewYork is allocated the block 172.16.1.0 through 172.16.15.0. This may also be represented as 172.16.0.0/20, signifying that the first four bits of the third octet in this range are all zeros, as is true for 172.16.1.0 through 172.16.15.0.

    hostname NewYork
    ...
19  interface Ethernet0
    ip address 172.16.1.1 255.255.255.0
    !
    interface Ethernet1
    ip address 192.168.1.1 255.255.255.0
    !
20  interface Ethernet2
    ip address 172.16.2.1 255.255.255.0
    !
    interface Serial0
    description New York to Chicago link
    ip address 172.16.250.1 255.255.255.0
    ip summary-address eigrp 10 172.16.0.0 255.255.240.0
    !
    interface Serial1
    description New York to Ames link
    bandwidth 56
    ip address 172.16.251.1 255.255.255.0
21  ip summary-address eigrp 10 172.16.0.0 255.255.240.0
    ...
    router eigrp 10
    network 172.16.0.0

NewYork now has two Ethernet segments (lines 19 and 20) from this block and has also been configured to send a summary route for this block (line 21) to its neighbors. The configuration of these routers is as shown in Figure 4-1. Here’s NewYork’s routing table:

    NewYork#sh ip route
    ...
         172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
    D       172.16.252.0/24 [90/2681856] via 172.16.250.2, 00:01:44, Serial0
    C       172.16.250.0/24 is directly connected, Serial0
    C       172.16.251.0/24 is directly connected, Serial1
22  D       172.16.0.0/20 is a summary, 00:03:22, Null0 
    C       172.16.1.0/24 is directly connected, Ethernet0
    C       172.16.2.0/24 is directly connected, Ethernet2
    D       172.16.50.0/20 [90/2195456] via 172.16.250.2, 00:01:45, Serial0
    D       172.16.100.0/20 [90/2707456] via 172.16.250.2, 00:01:45, Serial0
    C    192.168.1.0/24 is directly connected, Ethernet1

Note that NewYork installs a route to the null interface for the summarized address (172.16.0.0/20, as in line 22). Further, routers Ames and Chicago install this aggregated route (line 23) and not the individual 172.16.1.0/24 and 172.16.2.0/24 routes:

    Chicago#sh ip route
    ...
         172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
    C       172.16.252.0/24 is directly connected, Serial1
    C       172.16.250.0/24 is directly connected, Serial0
    D       172.16.251.0/24 [90/2681856] via 172.16.250.1, 00:02:30, Serial0
                            [90/2681856] via 172.16.252.2, 00:02:30, Serial1
    C       172.16.50.0/24 is directly connected, Ethernet0
23  D       172.16.0.0/20 [90/2195456] via 172.16.250.1, 00:02:12, Serial0   
    D       172.16.100.0/20 [90/2195456] via 172.16.252.2, 00:02:10, Serial1

The address aggregation commands on NewYork reduce the routing-table size in the rest of the network. Note that address aggregation plans need to be laid out ahead of time so that network numbers can be allocated accordingly. Thus, in the previous example, NewYork was allocated a block of 16 subnets:

172.16.96.0 through 172.16.15.0

Continuing this scheme, Ames may be allocated a block of 16 addresses that envelop the network number it is currently using (172.16.100.0):

172.16.96.0 through 172.16.111.0

and Chicago may be allocated a block of 16 addresses that envelop the network number it is currently using (172.16.50.0):

172.16.48.0 through 172.16.63.0

Ames could now be configured to summarize its block using the statement on its serial interfaces:

ip summary-address eigrp 10 172.16.0.0 255.255.240.0

and Chicago could be configured to summarize its block using the statement on its serial interfaces:

ip summary-address eigrp 10 172.16.0.0 255.255.240.0


[6] If the subnets overlapped, disabling route summarization would not do us any good. There are other methods to tackle duplicate address problems, such as Network Address Translation (NAT).

Get IP Routing now with the O’Reilly learning platform.

O’Reilly members experience books, live events, courses curated by job role, and more from O’Reilly and nearly 200 top publishers.