Route Summarization

Consider the router Phoenix, which connects to SantaFe and sends the RIP updates shown earlier:

192.100.1.48
192.100.1.64
192.100.2.0
10.0.0.0

Phoenix may have been configured as follows (see Figure 2-8, later in Chapter 2):

hostname Phoenix
ip subnet-zero
!
interface Ethernet 0
ip address 192.100.1.18 255.255.255.240
!
interface Ethernet 1
ip address 192.100.1.49 255.255.255.240
!
interface Ethernet 2
ip address 192.100.1.65 255.255.255.240
!
interface Ethernet 3
ip address 192.100.2.1 255.255.255.240
!
interface Ethernet 4
ip address 192.100.2.17 255.255.255.240
!
interface Ethernet 5
ip address 10.1.0.1 255.255.0.0
!
interface Ethernet 6
ip address 10.2.0.1 255.255.0.0
!
router rip
network 192.100.1.0
network 192.100.2.0
network 10.0.0.0

Phoenix did not send detailed routes for 192.100.2.0 or 10.0.0.0 when advertising to SantaFe because Phoenix summarized those routes. As I stated earlier, since Phoenix did not have interfaces on those networks, it couldn’t have made sense of those routes anyway.

Get IP Routing now with the O’Reilly learning platform.

O’Reilly members experience books, live events, courses curated by job role, and more from O’Reilly and nearly 200 top publishers.