O'Reilly logo

Cisco IOS Cookbook, 2nd Edition by Ian Brown, Kevin Dooley

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Configuring a Basic MPLS P Router

Problem

You want to set up the core of an MPLS network.

Solution

For the P routers in the core of the MPLS network, the primary requirement is to enable CEF and turn on MPLS on each of the interfaces that will be forwarding MPLS tagged packets. In this example, we have also enabled OSPF as a dynamic routing protocol within the MPLS core:

Router-P1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router-P1(config)#ip cef
Router-P1(config)#mpls ip
Router-P1(config)#interface FastEthernet0/0
Router-P1(config-if)#description connection to Router-PE2
Router-P1(config-if)#ip address 10.1.2.11 255.255.255.0
Router-P1(config-if)#mpls ip
Router-P1(config-if)#exit
Router-P1(config)#interface Serial0/0
Router-P1(config-if)#description connection to Router-PE1
Router-P1(config-if)#ip address 10.1.1.14 255.255.255.252
Router-P1(config-if)#mpls ip
Router-P1(config-if)#exit
Router-P1(config)#interface Serial0/1
Router-P1(config-if)#description connection to Router-PE3
Router-P1(config-if)#ip address 10.1.1.10 255.255.255.252
Router-P1(config-if)#mpls ip
Router-P1(config-if)#exit
Router-P1(config)#interface Loopback0
Router-P1(config-if)#ip address 10.0.0.11 255.255.255.255
Router-P1(config-if)#exit
Router-P1(config)#router ospf 99
Router-P1(config-router)#router-id 10.0.0.11
Router-P1(config-router)#network 10.0.0.0 0.255.255.255 area 0
Router-P1(config-router)#exit
Router-P1(config)#end
Router-P1#

Discussion

There are several things to ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required