O'Reilly logo

Cisco IOS Cookbook, 2nd Edition by Ian Brown, Kevin Dooley

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Configuring Bidirectional PIM

Problem

You want to use Bidirectional PIM to improve efficiency of your sparse-mode multicast network.

Solution

To use Bidirectional PIM, you must configure all of the routers in your network to support this method of building multicast forwarding trees. The RP configuration looks like this:

Router-RP1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router-RP1(config)#ip multicast-routing
Router-RP1(config)#ip pim bidir-enable
Router-RP1(config)#ip pim rp-address 192.168.12.1 bidir
Router-RP1(config)#ip pim rp-candidate Loopback0 group-list 15 bidir
Router-RP1(config)#ip pim bsr-candidate Loopback0 1
Router-RP1(config)#access-list 15 permit 239.5.5.0 0.0.0.255
Router-RP1(config)#access-list 15 deny any
Router-RP1(config)#interface Loopback0
Router-RP1(config-if)#ip address 192.168.12.1 255.255.255.255
Router-RP1(config-if)# ip pim sparse-mode
Router-RP1(config-if)#exit
Router-RP1(config)#interface FastEthernet0/0
Router-RP1(config-if)#ip address 192.168.1.1 255.255.255.0
Router-RP1(config-if)#ip pim sparse-mode
Router-RP1(config-if)#exit
Router-RP1(config)#interface Serial1/0
Router-RP1(config-if)#ip address 192.168.2.5 255.255.255.252
Router-RP1(config-if)#ip pim sparse-mode
Router-RP1(config-if)#exit
Router-RP1(config)#end
Router-RP1#

And the other multicast routers in this network will be configured to use Bidirectional PIM for this RP, as follows:

Router1#configure terminal  Enter configuration commands, one per line. ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required