O'Reilly logo

Cacti 0.8 Network Monitoring by S. M. Ibrahim Lavlu, Dinangkur Kundu

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Chapter 2. Prerequisites and Installing Cacti on Linux

In the first chapter, we learned some basic information about Cacti and SNMP. In this chapter, we will install Cacti on our localhost. Cacti runs best on Unix/Linux systems. In this book, all the examples are based on Debian Linux. If you are running a different distribution, you should be able to simply replace apt-get install with the appropriate command (urpmi, yum, and so on), like for centos you have to use yum install.

Cacti's prerequisites

Cacti has some prerequisites. You need to install these packages before installing Cacti:

  • RRDTool1.0.49 or higher.

  • NET-SNMP.

  • MySQL4.1.x or higher.

  • PHP 4.3.6 or higher.

  • Apache/IIS or any other web server.

We will also need to install some other ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required