O'Reilly logo
  • Arif Qureshi thinks this is interesting:

Step 3 – installing Ruby

Ruby is available in many different implementations and versions. Ruby 1.8.7 is still present on a lot of systems, but it's best avoided as it's incompatible with a lot of gems that you'll want to use.

Mac OS X comes with a preinstalled version of Ruby, but it is too old to be useful.

In such cases, you need to install a more recent version of Ruby.

At the time of writing, Ruby 1.9 is the recommended version. While Ruby 2.0 has just come out, it may cause some compatibility problems; so to start with, you should skip it.



Cover of Instant Sinatra Starter


Sinatra install 3