O'Reilly logo
  • regis hattori thinks this is interesting:

But we might want to think of a better name for tenant(). The following may improve things a bit

From

Cover of Implementing Domain-Driven Design

Note

improve??? findTenant...